超强波段副图指标源码,k线变色的波段指标源码

内容导航:
  • 当前公式 : 超级波段王 (指标画线公式)
  • ...组合指标公式,谁可以解释一下。我看不明白,源代码如下
  • 波段主图买卖提示指标源码
  • 网上的一个 通达信 副图指标,求老师编写为选股公式,要求“黑马出现”选...
  • 怎么能把炒股软件里的,波段高低点显示调出来?
  • k线高低点标注如何设置
  • 当前公式 : 超级波段王 (指标画线公式)】

    超级波段王(主图)
    趋势线:MA(CLOSE,21),ColorFFFfff,linicK2;
    生命线:MA(CLOSE,43),Color00Ffff,linicK2;
    牛熊分界线:MA(CLOSE,250),Color0000ff,linicK3;
    TY:=C;
    HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);
    LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);
    A:=REF(C,BARSLAST(HD));
    B:=REF(C,BARSLAST(LD));
    T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
    T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
    波浪顶:IF(T1,A,A),COLORFF00FF,POINTDOT,LINICK1;
    STICKLINE(T1,A,A,9,0),COLORFF00FF;
    波浪底:IF(T2,B,B),COLOR80FF00,POINTDOT,LINICK1;
    Var3:=LLV(最高价,240);
    Var4:=100*(收盘价-Var3)/Var3;
    Var5:=(收盘价-LLV(最低价,528))/(HHV(最高价,528)-LLV(最低价,528))*100;
    Var6:=(收盘价-LLV(收盘价,530))/(HHV(收盘价,530)-LLV(收盘价,530))*100;
    Var7:=0;
    Var8:=MA(HHV(收盘价-REF(收盘价,1),0),34)/MA(ABS(收盘价-REF(收盘价,1)),7)*100;
    Var9:=MA(HHV(收盘价-REF(收盘价,1),0),13)/MA(ABS(收盘价-REF(收盘价,1)),13)*100;
    VarA:=BARSCOUNT(收盘价);
    VarB:=Var8<20 AND Var9<23 AND VarA>35;
    VarC:=VarB AND COUNT(VarB,1)=1;
    VarD:=EMA(收盘价,21)-EMA(收盘价,8);
    VarE:=EMA(VarD,5);
    VarF:=TROUGH(3,6,1)<4 AND CROSS(VarD,VarE);
    Var10:=IF(TROUGH(3,16,1)=0 AND 最高价>最低价+0.04,4,0);
    Var11:=ZIG(3,6)>REF(ZIG(3,6),1)
    AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2)
    AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
    Var12:=ZIG(3,6)<REF(ZIG(3,6),1)
    AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2)
    AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
    Var13:=ZIG(3,22)>REF(ZIG(3,22),1)
    AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2)
    AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
    Var14:=ZIG(3,22)<REF(ZIG(3,22),1)
    AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2)
    AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
    Var15:=ZIG(3,51)>REF(ZIG(3,51),1)
    AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2)
    AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
    Var16:=ZIG(3,51)<REF(ZIG(3,51),1)
    AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2)
    AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
    Var17:=ZIG(3,72)>REF(ZIG(3,72),1)
    AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2)
    AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
    Var18:=ZIG(3,72)<REF(ZIG(3,72),1)
    AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2)
    AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
    Var19:=EMA(收盘价,2)-EMA(收盘价,150);
    Var1A:=EMA(Var19,100);
    Var1B:=2*(Var19-Var1A);
    Var1C:=POW(Var1B,3)*0.1+POW(Var1B,1);
    Var1D:=SQRT(SQRT(最低价*最高价*开盘价*收盘价));
    Var1E:=EMA(Var1D*0.97,3);
    Var1F:=(最高价+最低价+收盘价)/3;
    Var20:=(Var1F-MA(Var1F,14))/(0.015*AVEDEV(Var1F,14));
    Var21:=CROSS(Var1E,最低价);
    买点1:=Var10;
    买点2:=(Var11+Var13+Var15+Var17);
    卖点1:=(Var12+Var14+Var16+Var18),linick2;
    Var22:=买点1 AND VarF AND VarC AND Var21 AND Var4<0
    AND Var5=0 AND Var6=0 AND Var20<(-110);
    VAR1:=MA(收盘价,5);
    VAR2:=MA(收盘价,10);
    VAR31:=MA(收盘价,30);
    VARB1:=SUM(收盘价*成交量*100,28)/SUM(成交量*100,28);
    VARC1:=INTPART(VARB1*100)/100;
    VARD1:=EMA(收盘价,5)-EMA(收盘价,10);
    VARE1:=EMA(VARD1,9);
    VAR131:=REF(VARE1,1);
    VAR141:=VARE1;
    VAR151:=VAR141-VAR131;
    VAR161:=REF(VARD1,1);
    VAR171:=VARD1;
    VAR181:=VAR171-VAR161;
    VAR191:=开盘价;
    VAR1A1:=收盘价;
    DRAWTEXT(买点1>0,L+0.1,'▲'),colorred;
    DRAWTEXT(买点2>0,L+0.1,'▲'),COLORFF00FF;
    DRAWTEXT(卖点1>0,H+0.01,'▼'), COLOR33FF33;
    超级波段王(副图)
    {中短线}
    {买入点、卖出点判断的精度极高!}
    Var3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
    Var4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
    Var5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
    Var6:=(Var3+Var4+Var5)/3;
    Var7:=EMA(Var6,5);
    指标: EMA(EMA(Var3,5),5)*3, COLORSTICK;
    Var8:=IF(Var6<=-20,10,0);
    Var9:=HHV(Var8,10);
    STICKLINE(Var8=10,20,10,5,0),COLOR6666FF;
    VarA:=IF(Var9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
    K:EMA(Var7,5)*2, , COLORff00ff;
    D:EMA(K,5), , COLORWHITE;
    J:K*3-D*2, ,COLORYELLOW;
    VarB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;
    换手: VOL/CAPITAL*100, , COLORYELLOW;
    成交〖万手〗: VOL/10000, ,COLORWHITE;
    DRAWTEXT(Var8=10 AND FILTER(Var8=10,5),-10{15},'近底部'),linick1,COLORYELLOW;
    STICKLINE(Var8=10 AND FILTER(Var8=10,5),-1.6{20},-10,5,0),coloryellow;
    DRAWTEXT(VarA=20,15,'底部'),linick1,colorwhite;
    STICKLINE((VarA=20),0,10,5,0),colorwhite;
    VARC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG
    (3,5),2)<=REF(ZIG(3,5),3));
    VARD:=(ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG
    (3,5),2)>=REF(ZIG(3,5),3));
    STICKLINE((VARC=1),(-14),0,4,0),Color0000FF;
    DRAWTEXT((VARC=1),(-14),'买'),Color0000FF;
    STICKLINE((VARD=1),14,0,4,0),Color00FF00;
    DRAWTEXT((VARD=1),18,'卖'),Color00FF00;
    VarE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
    VarF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
    ((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
    Var10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
    ((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
    Var11:=VarF<REF(Var10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
    DRAWTEXT(Var11 AND COUNT(Var11,30)=1,15,'大资金活动'),linick1,COLORff00ff;
    STICKLINE(Var11 AND COUNT(Var11,30)=1,1,10,5,0),colorff00ff;
    Var12:=(HIGH+LOW+CLOSE)/3;
    Var13:=(Var12-MA(Var12,14))/(0.015*AVEDEV(Var12,14));
    Var14:=(Var12-MA(Var12,70))/(0.015*AVEDEV(Var12,70));
    Var15:=IF(Var13>=150 AND Var13<200 AND Var14>=150 AND Var14<200,10,0);
    Var16:=IF(Var13<=-150 AND Var13>-200 AND Var14<=-150 AND Var14>-200,-10,Var15);
    Var17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
    Var18:=100-ABS(Var17);
    Var19:=IF(Var18<90,Var18,100);
    Var1A:=IF(VarE>0,VarE,0);
    Var1B:=IF(Var14>=200 AND Var13>=150,15,IF(Var14<=-200 AND Var13<=-150,-15,Var16))+60;
    Var1C:=Var1A>48 AND Var1B>60 AND Var19<100;
    DRAWTEXT(Var1C AND COUNT(Var1C,30)=1,15,'大笔出货'),linick1,COLORffcc66;
    STICKLINE(Var1C AND COUNT(Var1C,30)=1,0,10,5,0),colorffcc66;
    http://www.88gs.com/soft/sort013/sort03/down-8443.html

    ...组合指标公式,谁可以解释一下。我看不明白,源代码如下】

    {波段线}
    VAR2:=(HIGH+LOW+CLOSE*2)/4;
    VAR3:=EMA(VAR2,21);
    VAR4:=STD(VAR2,21);
    VAR5:=((VAR2-VAR3)/VAR4*100+200)/4;
    VAR6:=(EMA(VAR5,5)-25)*1.56;
    {AK: EMA(VAR6,2)*1.22;
    AD1: EMA(AK,2);
    AJ: 3*AK-2*AD1;
    DRAWTEXT(CROSS(AK,AD1),AK,'*'),COLORRED;
    DRAWTEXT(CROSS(AD1,AK),AK,'*'),COLORWHITE;}
    {金手指}
    RA:=LLV(LOW,35);
    RB:=HHV(HIGH,30);
    RC:=EMA((CLOSE-RA)/(RB-RA)*4,4)*19;
    近日均价:=MA(CLOSE,5),COLORYELLOW,LINICK2;
    DRAWICON(RC<6 AND 100*(HHV(HIGH,19)-CLOSE)/(HHV(HIGH,19)-LLV(LOW,19))>97,100,11);
    LC:=REF(CLOSE,1);
    RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
    ZL:=EMA( (CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2)*5;
    SH:=EMA( (CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7)*5;
    BT1:=CROSS(RSI1,25);
    BT2:=CROSS(ZL,SH) AND ZL<-10;
    BT:=FILTER(COUNT(BT1 OR BT2,3)>=2,3);
    BIAS:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
    VARC:=LOW;
    VARD:=REF(LOW,1);
    VARE:=SMA(ABS(VARC-VARD),3,1)/SMA(MAX(VARC-VARD,0),3,1)*100;
    VARF:=MA(VARE/10,3);
    VAR10:=LLV(LOW,30);
    VAR11:=HHV(VARF,30);
    MA(IF(LOW<=VAR10,(VARF+VAR11*2)/5,0),3);
    VAR1B:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
    VAR2B:=SMA(ABS(LOW-VAR1B),13,1)/SMA(MAX(LOW-VAR1B,0),10,1);
    VAR3B:=EMA(VAR2B,10);
    VAR4B:=LLV(LOW,33);
    VAR5B:=EMA(IF(LOW<=VAR4B,VAR3B,0),3);
    {主力进场:IF(VAR5B>REF(VAR5B,1),VAR5B,0),COLORRED;}
    STICKLINE(VAR5B>REF(VAR5B,1),0,VAR5B*2,2,0 ),COLORYELLOW;
    洗盘:IF(VAR5B<REF(VAR5B,1),VAR5B,0),COLORLIGREEN;
    VARR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
    VARR2:=SMA(ABS(LOW-VARR1),13,1)/SMA(MAX(LOW-VARR1,0),10,1);
    VARR3:=EMA(VARR2,10);
    VARR4:=LLV(LOW,33);
    VARR5:=EMA(IF(LOW<=VARR4,VARR3,0),3);
    STICKLINE(VARR5>REF(VARR5,1),0,VARR5,2,0 ),COLORGREEN;
    STICKLINE(VARR5<REF(VARR5,1),0,VARR5*2,2,0),COLORRED;
    找主力吸筹提款:VARR5>REF(VARR5,4) {AND C>REF(C,1)},COLORMAGENTA;
    VAR2C:=(HIGH+LOW+CLOSE*2)/4;
    VAR3C:=EMA(VAR2C,7);
    VAR4C:=STD(VAR2C,7);
    VAR5C:=(VAR2C-VAR3C)*100/VAR4;
    VAR6C:=EMA(VAR5C,3);
    {WW:(EMA(VAR6C,5)+100)/2-3,COLORFF00FF;
    MM:HHV(WW,3),COLORFF3333;}
    AAA:=AMOUNT/VOL/100;
    主力进场:IF(VAR5B>REF(VAR5B,1),VAR5B*1.5,0),COLORRED,LINICK2;
    {吸筹}
    VAR2Q:=REF(LOW,1);
    VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
    VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
    VAR5Q:=LLV(LOW,30);
    VAR6Q:=HHV(VAR4Q,30);
    VAR7Q:=IF(MA(CLOSE,58),1,0);
    VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/618*VAR7Q;
    VAR9Q:=IF(VAR8Q>100,100,VAR8Q);
    吸筹:STICKLINE(VAR9Q>-120,0,VAR9Q,6,1),COLORRED;
    VARY2:=REF(LOW,1);
    VARY3:=SMA(ABS(LOW-VARY2),3,1)/SMA(MAX(LOW-VARY2,0),3,1)*100;
    VARY4:=EMA(IF(CLOSE*1.3,VARY3*10,VARY3/10),3);
    VARY5:=LLV(LOW,30);
    VARY6:=HHV(VARY4,30);
    VARY7:=IF(MA(CLOSE,58),1,0);
    VARY8:=EMA(IF(LOW<=VARY5,(VARY4+VARY6*2)/2,0),3)/618*VARY7;
    VARY9:=IF(VARY8>100,100,VARY8);
    吸筹2:STICKLINE(VARY9>-120,0,VARY9/3,2,1),COLORMAGENTA;
    LCC:=REF(CLOSE,1);
    RSI:=SMA(MAX(CLOSE-LCC,0),4.1,1)/SMA(ABS(CLOSE-LCC),4.1,1)*100,COLORYELLOW,LINICK1;
    黄买:FILTER((REF(CLOSE,2)<CLOSE AND RSI<25),7),COLORYELLOW;
    STICKLINE(黄买,0,-40,10,1),COLORYELLOW;
    黄卖:=FILTER((REF(CLOSE,2)>CLOSE AND RSI>80),7);
    STICKLINE(黄卖,100,82,10,0),COLORBLUE;
    红买:FILTER(CROSS(RSI,11),7),COLORRED;
    STICKLINE(红买,0,-30,6,0),COLORRED;
    红卖:=FILTER(CROSS(89,RSI),7);
    STICKLINE(红卖,100,88,8,0),COLORCYAN;
    绿买:FILTER(CROSS(RSI,20),7),COLOR00FF00;
    STICKLINE(绿买,0,-20,6,0),COLORMAGENTA;
    绿卖:=FILTER(CROSS(80,RSI),7);
    STICKLINE(绿卖,100,94,6,0),COLOR00FF00;
    ★遵守纪律★:100,COLORRED;
    ★交易之魂★:100,COLORRED;
    ZLC:= EMA((WINNER(CLOSE) * 70),3);
    SHC:= EMA(((WINNER((CLOSE * 1.1)) - WINNER((CLOSE * 0.9))) * 80),3);
    主力控盘: ((ZLC / (ZLC+ SHC)) * 100),COLOR00FFFF,LINICK2;
    上限: HHV(主力控盘,20),COLORGREEN,LINICK2;
    下限: LLV(主力控盘,20),COLORRED,LINICK2;
    中线:(上限 + 下限)/2,COLORYELLOW,POINTDOT,LINICK2;
    {60,LINICK4,POINTDOT,COLORYELLOW;}
    {10,LINICK4,POINTDOT,COLORFF00FF;}
    VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
    VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
    VAR400:=EMA(VAR300,5);
    操盘:=3*VAR300-2*VAR400;
    A1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
    STICKLINE(A1,30,0,4,0),COLOR770077;
    STICKLINE(A1,30,0,3,0),COLOR990099;
    STICKLINE(A1,30,0,2,0),COLORBB00BB;
    STICKLINE(A1,30,0,1,0),COLORWHITE;
    STICKLINE(A1,30,0,0.3,0),COLORFF00FF;
    DRAWTEXT(A1,36,'满仓'),COLORRED;
    DRAWTEXT(A1,36,'满仓'),COLORRED;
    AK: EMA(VAR6,2)*1.22;
    AD1: EMA(AK,2);
    AJ: 3*AK-2*AD1;
    DRAWTEXT(CROSS(AK,AD1),AK,'*'),COLORRED;
    DRAWTEXT(CROSS(AD1,AK),AK,'*'),COLORWHITE;
    WW:(EMA(VAR6C,5)+100)/2-3,COLORFF00FF;
    MM:HHV(WW,3),COLORFF3333;
    DRAWTEXT(BT1,0,'□'),COLORYELLOW;
    DRAWTEXT(BT,0,'■'),COLORYELLOW;
    DRAWICON(CROSS(85,RSI1),102,15);{饭跑跑}
    DRAWICON(CROSS(RSI1,25),10,26);{金钻}
    DRAWICON(CROSS(ZL,SH) AND ZL<-10,20,24);{蓝钻}
    DRAWICON(CROSS(BIAS,-12),-10,13);{BIAS买点};

    波段主图买卖提示指标源码】

    P1:=5;P2:=10;P3:=20;P4:=30;{波段极品}

    卖出线:=98;

    阶段卖:=96;

    趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA

    (SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

    底部:=10;

    买入警戒:STICKLINE(趋势<=10,HIGH,LOW,0.5,0),COLOR00FF00;

    STICKLINE(趋势<=10,OPEN,CLOSE,5,1),COLOR00FF00;

    买入信号:DRAWICON(CROSS(趋势,底部),LOW,8);

    卖出警戒:STICKLINE(趋势>=阶段卖,HIGH,LOW,0.5,0),COLORBLUE;

    STICKLINE(趋势>=阶段卖,OPEN,CLOSE,6,1),LINICK2,COLORBLUE;

    卖出:DRAWICON(CROSS(卖出线,趋势),HIGH,9);

    MA(CLOSE,5);

    MA(CLOSE,12);

    DRAWICON(CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),HIGH*1.035,1);

    DRAWTEXT(CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),HIGH*1.02,'卖吧');

    J:MA(CLOSE,20)+2*STD(CLOSE,20);

    Y:MA(CLOSE,20)-2*STD(CLOSE,20);

    DRAWICON(CROSS((REF(HIGH,1)+REF(LOW,1))/2,J),H*1.035,4);

    DRAWICON(CROSS(Y,(REF(HIGH,1)+REF(LOW,1))/2),L/1.035,5);

    理性投资,系统学习个股操作指标、技术、选股思路,掌握高手实战要诀,关注鸿股堂资讯通公众号(hong11026)

    ​作者id:gu12626

    网上的一个 通达信 副图指标,求老师编写为选股公式,要求“黑马出现”选...】

    XG:FILTER(TROUGHBARS(3,15,1)<4,6);
    你要求的这个是未来函数,建议不用。
    所谓未来,通俗一点就是“马后炮”。
    当你能看到这个:黑码出现 的时候,都已经成为过去,成为历史了。
    或这你今天可以看到,当出现比现在的价格更低的时候,那这个线会随着价格的走低而变化,俗称:信号漂移。

    怎么能把炒股软件里的,波段高低点显示调出来?】

    单一高点有的软件有K主图就有,有的就没有,波段高低点可以这样选择:单击右键,选择主图指标,选择箱体,自己调整天数就可以了。不同的软件可能有所不同。

    k线高低点标注如何设置】

    K线上默认已经在最高点和最低点画上了小横线。
    如果你是要显示波段的高低点,可以点开画线工具,点下小齿轮,把“风格/智能设置”中的显示波段高价和低价打钩

    标签: 超强波段副图指标源码 超牛波段指标公式源码波段神奇高低点指标编辑